MyTrails Home Maps

Lignes parasites dans l'affichage des traces


#1

Bonjour,

Je ne sais pas si le problème a été introduit avec la dernière mise à jour ou s’il était déjà présent dans la précédente version, mais je constate que l’affichage des traces présente, à certains niveaux de zoom, des lignes droites parasites dont l’épaisseur va en décroissant d’une extrémité à l’autre, apparemment entre certains points de navigation. Le phénomène se produit avec presque toutes les traces et quel que soit le fond de carte utilisé.
Je n’avais pas ce problème avec ces mêmes traces sur mon précédent smartphone qui tournait avec une vieille version (celle qui précédait la refonte de l’interface).


Ci-joint trois captures d’écran où l’on voit que la ligne parasite n’apparaît qu’au niveau de zoom intermédiaire.

Capture sans


When plotting a trail straight lines appear on map
#4

En effet, c’est un problème que j’essaie de résoudre depuis de nombreux mois, mais qui n’apparaît que sur un petit nombre de terminaux et aucun des miens. Or, la première étape pour pouvoir corriger un bug non-trivial est de le reproduire.

Je vous propose que chacun des utilisateurs qui a le problème fournisse les infos suivantes:

  • modèle de téléphone
  • version d’Android
  • est-ce que les lignes parasites
    • changent lorsqu’on change de niveau de zoom et n’influencent pas la longueur de la trace (et n’apparaissent pas lorsqu’on ouvre la trace dans une autre appli)
    • ou est-ce qu’elles sont relativement fixes vis-à-vis du zoom, et influencent la longueur de la trace (et apparaissent dans d’autres applis)

Un sujet similaire à celui-ci en anglais.


#5

Bonjour,

C’est en effet le même problème que celui qui est décrit dans le signalement en anglais. J’ai cru que les lignes fantômes étaient liées aux points de navigation, mais ce n’est pas le cas, car elles persistent si on supprime ces derniers de la trace. Ce sont en fait les points singuliers du parcours (rebroussement de chemin, virages en épingle…) qui les provoquent.

Mon téléphone est un Galaxy A8 sous Oréo version d’origine (non rooté), et j’ai constaté le même phénomène sur mon Xperia Arc S sous ICS rooté.

La trace s’affiche correctement sous VisuGPX ou avec une ancienne version de Mytrails. La voici en partage: https://share.orange.fr/#bvkH0me9sR105f572398

Je vais regarder de plus près ce qu’il en est du calcul de distance.

Merci.


#6

Pour compléter mon précédent message, je n’ai pas relevé d’anomalies dans le calcul de la distance ni sur l’ensemble des traces affectées ni au voisinage des points d’où partent les lignes qui vont vers le début du parcours. Le seul dénominateur commun entre les différents cas tient au fait qu’il s’agit à chaque fois de virages serrés, semble-t-il.


#7

OK - my phone is a Samsung Galaxy A3 (2017) model SM-A320FL using Android version 8.0.0 (Experience version 9.0).
A couple of further points that may help:

  1. I imported a .gpx file recorded on another phone and a couple of parasite straight lines appeared when I opened the same file in My Trails on my phone. The lines did not show on the other phone.
  2. I recorded some trials last year which were fine then. When I looked at same .gpx files this year, parasite lines suddenly appeared.
  3. The number of parasite lines showing up on the My Trails map is dependant on the zoom level.

#8

Bonjour,
j’vais ce problème avec un Wiko Iggy sous Jelly Bean.
Ensuite j’ai eu ce problème avec mon Samsung S4 GT 19505 sous Android 5.0.1. Mais depuis la version 2.1 (il me semble), je n’ai plus le problème.
Cldt
Sylvain